PyLucid v1.2.0 changes

About the changes https://github.com/jedie/PyLucid/compare/v1.1.2...v1.2.0

It's not really backward incompatible, because no admin action is needed for update. The only backward incompatible changes are the PyLucid search API and that is only interesting for developers ;)

main goals are:

We added a preferences value to specify the max hit count to skip a plugin search. Go to:

  • Django admin site / Dbpreferences / Preferences / SearchPreferencesForm

(The default value is 100)

how to update

Update with cli script and select both PyLucid and django-dbtemplates

If you use DjangoBB Forum as a plugin, update the plugin, too.

more information

With commit 8c47778 we changed the search API a little bit: We split the plugin search function, to filter the real search if there are too much hits.